package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w-.]+)@([\w-]+)(\.[\w.-]+)$`)
var str = `Created by David Carroll for Question on SoloLearn:
- https://www.sololearn.com/Discuss/1940608/?ref=app
- Also see: For List of TLD possibilities:
- https://regex101.com/r/9ugQHy/4
-----------------
Sample Data
-----------------
example@example.com
example@example.net
example@example.com
d.c-123@some-domain.uk.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}