// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w-.]+)@([\w-]+)(\.[\w.-]+)$").unwrap();
let string = "Created by David Carroll for Question on SoloLearn:
- https://www.sololearn.com/Discuss/1940608/?ref=app
- Also see: For List of TLD possibilities:
- https://regex101.com/r/9ugQHy/4
-----------------
Sample Data
-----------------
example@example.com
example@example.net
example@example.com
d.c-123@some-domain.uk.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}