import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w-.]+)@([\\w-]+)(\\.[\\w.-]+)$";
final String string = "Created by David Carroll for Question on SoloLearn:\n"
+ " - https://www.sololearn.com/Discuss/1940608/?ref=app\n"
+ " - Also see: For List of TLD possibilities:\n"
+ " - https://regex101.com/r/9ugQHy/4\n"
+ "-----------------\n"
+ "Sample Data\n"
+ "-----------------\n\n"
+ "example@example.com\n"
+ "example@example.net\n"
+ "example@example.com\n"
+ "d.c-123@some-domain.uk.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}