const regex = /^([\w-.]+)@([\w-]+)(\.[\w.-]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w-.]+)@([\\w-]+)(\\.[\\w.-]+)$', 'gm')
const str = `Created by David Carroll for Question on SoloLearn:
- https://www.sololearn.com/Discuss/1940608/?ref=app
- Also see: For List of TLD possibilities:
- https://regex101.com/r/9ugQHy/4
-----------------
Sample Data
-----------------
example@example.com
example@example.net
example@example.com
d.c-123@some-domain.uk.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}