#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$"
Local $sString = "9:00 AM" & @CRLF & _
"12:30 PM" & @CRLF & _
"3:30 PM" & @CRLF & _
"5:00 PM" & @CRLF & _
"12:30 PM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12:34 AM" & @CRLF & _
"3:21 PM" & @CRLF & _
"4:56 AM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")