package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$`)
var str = `9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}