const regex = /^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-1]?[0-9]|2[0-3]):[0|3][0]\\s[A|P]M$', 'mg')
const str = `9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}