use strict;
my $str = '9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM';
my $regex = qr/^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}