import re
regex = re.compile(r"^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$", flags=re.MULTILINE)
test_str = ("9:00 AM\n"
"12:30 PM\n"
"3:30 PM\n"
"5:00 PM\n"
"12:30 PM\n\n\n"
"12:34 AM\n"
"3:21 PM\n"
"4:56 AM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")