using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$";
string input = @"9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}