using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<<(?<placeholder>.*?)>>(?<spaces_after>\s*)";
string substitution = @"\n<<${placeholder}>>${spaces_after}\n";
string input = @"My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}