$re = '/<<(?<placeholder>.*?)>>(?<spaces_after>\s*)/';
$str = 'My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.';
$subst = "\n<<${placeholder}>>${spaces_after}\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;