re = /<<(?<placeholder>.*?)>>(?<spaces_after>\s*)/
str = 'My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.'
subst = '\\n<<${placeholder}>>${spaces_after}\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result