import Foundation
let pattern = #"<<(?<placeholder>.*?)>>(?<spaces_after>\s*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n<<${placeholder}>>${spaces_after}\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)