const regex = new RegExp('<<(?<placeholder>.*?)>>(?<spaces_after>\\s*)', 'g')
const str = `My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.`;
const subst = `\n<<${placeholder}>>${spaces_after}\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);