package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<<(?<placeholder>.*?)>>(?<spaces_after>\s*)`)
var str = `My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.`
var substitution = "\n<<${placeholder}>>${spaces_after}\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}