use strict;
my $str = 'My name is <<yourName>> and I am working in the <<Team Name>> team
as a <<yourTitle>>.';
my $regex = qr/<<(?<placeholder>.*?)>>(?<spaces_after>\s*)/p;
my $subst = '\\n<<${placeholder}>>${spaces_after}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";