using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)";
string substitution = @"\1=\2";
string input = @"air.BattleofZombies 0.0008 0.0006 -0.0027
air.BattleofZombies 0.0008
air.BattleofZombies 0.0008 7877
air.BattleofZombies -0.0008 656 -984.98";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}