import Foundation
let pattern = #"(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
air.BattleofZombies 0.0008 0.0006 -0.0027
air.BattleofZombies 0.0008
air.BattleofZombies 0.0008 7877
air.BattleofZombies -0.0008 656 -984.98
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1=\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)