import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+)\\s+(-?\\d+(?:\\.\\d+)?(?:\\s+-?\\d+(?:\\.\\d+)?)*)";
final String string = "air.BattleofZombies 0.0008 0.0006 -0.0027\n"
+ "air.BattleofZombies 0.0008\n"
+ "air.BattleofZombies 0.0008 7877\n"
+ "air.BattleofZombies -0.0008 656 -984.98";
final String subst = "\\1=\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}