import re
regex = re.compile(r"(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)", flags=re.MULTILINE)
test_str = ("air.BattleofZombies 0.0008 0.0006 -0.0027\n"
"air.BattleofZombies 0.0008\n"
"air.BattleofZombies 0.0008 7877\n"
"air.BattleofZombies -0.0008 656 -984.98")
subst = "\\1=\\2"
result = regex.sub(subst, test_str)
if result:
print(result)