$re = '/(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)/m';
$str = 'air.BattleofZombies 0.0008 0.0006 -0.0027
air.BattleofZombies 0.0008
air.BattleofZombies 0.0008 7877
air.BattleofZombies -0.0008 656 -984.98';
$subst = "\1=\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;