#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf"
Local $sString = "file-name-en.pdf" & @CRLF & _
"file-name-ja.pdf" & @CRLF & _
"file-name-ptbr.pdf" & @CRLF & _
"file-name-ptpt.pdf" & @CRLF & _
"file-name-pt-br.pdf" & @CRLF & _
"file-name-pt-pt.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")