package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf`)
var str = `file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}