const regex = new RegExp('-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\\.pdf', 'g')
const str = `file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}