// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf").unwrap();
let string = "file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}