$re = '~-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf~';
$str = 'file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);