import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\\.pdf";
final String string = "file-name-en.pdf\n"
+ "file-name-ja.pdf\n"
+ "file-name-ptbr.pdf\n"
+ "file-name-ptpt.pdf\n"
+ "file-name-pt-br.pdf\n"
+ "file-name-pt-pt.pdf";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}