re = /-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf/
str = 'file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end