use strict;
my $str = 'file-name-en.pdf
file-name-ja.pdf
file-name-ptbr.pdf
file-name-ptpt.pdf
file-name-pt-br.pdf
file-name-pt-pt.pdf';
my $regex = qr~-([a-z]{2}(?:-[a-z]{2})?|[a-z]{4})\.pdf~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}