#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(<)(?i)(script))([^\/].+?)(>)"
Local $sString = "<script type="text/javascript">" & @CRLF & _
"" & @CRLF & _
" inner_text_1" & @CRLF & _
" <c:set var="" value="">inner_text_2</c:set>" & @CRLF & _
"" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\/].+?)(>)" & @CRLF & _
"(?<=(<)(?i)(script))([^\/].+?)(>)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")