const regex = /(?<=(<)(?i)(script))([^\/].+?)(>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(<)(?i)(script))([^\\\/].+?)(>)', '')
const str = `<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>
(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\\/].+?)(>)
(?<=(<)(?i)(script))([^\\/].+?)(>)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}