import Foundation
let pattern = #"(?<=(<)(?i)(script))([^\/].+?)(>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>
(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\/].+?)(>)
(?<=(<)(?i)(script))([^\/].+?)(>)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}