using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(<)(?i)(script))([^\/].+?)(>)";
string input = @"<script type=""text/javascript"">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>
(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\/].+?)(>)
(?<=(<)(?i)(script))([^\/].+?)(>)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}