import re
regex = re.compile(r"(?<=(<)(?i)(script))([^\/].+?)(>)")
test_str = ("<script type=\"text/javascript\">\n\n"
" inner_text_1\n"
" <c:set var=\"\" value=\"\">inner_text_2</c:set>\n\n"
"</script>\n\n"
"(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\\/].+?)(>)\n"
"(?<=(<)(?i)(script))([^\\/].+?)(>)")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")