$re = '/(?<=(<)(?i)(script))([^\/].+?)(>)/';
$str = '<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>
(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\\/].+?)(>)
(?<=(<)(?i)(script))([^\\/].+?)(>)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);