import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(<)(?i)(script))([^\\/].+?)(>)";
final String string = "<script type=\"text/javascript\">\n\n"
+ " inner_text_1\n"
+ " <c:set var=\"\" value=\"\">inner_text_2</c:set>\n\n"
+ "</script>\n\n"
+ "(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\\/].+?)(>)\n"
+ "(?<=(<)(?i)(script))([^\\/].+?)(>)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}