const regex = /(<Title>).{6}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<Title>).{6}', 'g')
const str = `<Title>0001: Title1</Title>
<Title>0002: Title2</Title>
<Title>0003: Title3</Title>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);