$re = '/(<Title>).{6}/';
$str = '<Title>0001: Title1</Title>
<Title>0002: Title2</Title>
<Title>0003: Title3</Title>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;