use strict;
my $str = '<Title>0001: Title1</Title>
<Title>0002: Title2</Title>
<Title>0003: Title3</Title>';
my $regex = qr/(<Title>).{6}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";