// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<Title>).{6}").unwrap();
let string = "<Title>0001: Title1</Title>
<Title>0002: Title2</Title>
<Title>0003: Title3</Title>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}