import re
regex = re.compile(r"(<Title>).{6}")
test_str = ("<Title>0001: Title1</Title>\n"
"<Title>0002: Title2</Title>\n"
"<Title>0003: Title3</Title>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)