#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\d[^\/]+(?:\/\?.*|\/)?$"
Local $sString = "https://www.themoviedb.org/movie/746036-sdf" & @CRLF & _
"https://www.themoviedb.org/movie/746036" & @CRLF & _
"https://www.themoviedb.org/movie/746036?ff" & @CRLF & _
"https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf" & @CRLF & _
"https://www.themoviedb.org/movie/746036-33?ff=sdfsdf" & @CRLF & _
"https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf" & @CRLF & _
"https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs" & @CRLF & _
"https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf" & @CRLF & _
"" & @CRLF & _
"https://any.themoviedb.org/tv/12345-gg/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")