# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\d[^\/]+(?:\/\?.*|\/)?$"
test_str = ("https://www.themoviedb.org/movie/746036-sdf\n"
"https://www.themoviedb.org/movie/746036\n"
"https://www.themoviedb.org/movie/746036?ff\n"
"https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf\n"
"https://www.themoviedb.org/movie/746036-33?ff=sdfsdf\n"
"https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf\n"
"https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs\n"
"https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf\n\n"
"https://any.themoviedb.org/tv/12345-gg/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.