import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\d[^\\/]+(?:\\/\\?.*|\\/)?$";
final String string = "https://www.themoviedb.org/movie/746036-sdf\n"
+ "https://www.themoviedb.org/movie/746036\n"
+ "https://www.themoviedb.org/movie/746036?ff\n"
+ "https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf\n"
+ "https://www.themoviedb.org/movie/746036-33?ff=sdfsdf\n"
+ "https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf\n"
+ "https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs\n"
+ "https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf\n\n"
+ "https://any.themoviedb.org/tv/12345-gg/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}