package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\d[^\/]+(?:\/\?.*|\/)?$`)
var str = `https://www.themoviedb.org/movie/746036-sdf
https://www.themoviedb.org/movie/746036
https://www.themoviedb.org/movie/746036?ff
https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs
https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf
https://any.themoviedb.org/tv/12345-gg/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}