const regex = /\/\d[^\/]+(?:\/\?.*|\/)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\d[^\\\/]+(?:\\\/\\?.*|\\\/)?$', 'gm')
const str = `https://www.themoviedb.org/movie/746036-sdf
https://www.themoviedb.org/movie/746036
https://www.themoviedb.org/movie/746036?ff
https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs
https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf
https://any.themoviedb.org/tv/12345-gg/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}