$re = '/\/\d[^\/]+(?:\/\?.*|\/)?$/m';
$str = 'https://www.themoviedb.org/movie/746036-sdf
https://www.themoviedb.org/movie/746036
https://www.themoviedb.org/movie/746036?ff
https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs
https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf
https://any.themoviedb.org/tv/12345-gg/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);