use strict;
my $str = 'https://www.themoviedb.org/movie/746036-sdf
https://www.themoviedb.org/movie/746036
https://www.themoviedb.org/movie/746036?ff
https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs
https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf
https://any.themoviedb.org/tv/12345-gg/';
my $regex = qr/\/\d[^\/]+(?:\/\?.*|\/)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}