using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\d[^\/]+(?:\/\?.*|\/)?$";
string input = @"https://www.themoviedb.org/movie/746036-sdf
https://www.themoviedb.org/movie/746036
https://www.themoviedb.org/movie/746036?ff
https://www.themoviedb.org/movie/746036-fsdf?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf
https://www.themoviedb.org/movie/746036-33/?ff=sdfsdf/dfs
https://www.themoviedb.org/movie/746036-33dfdsf/s?sdfsdf/?dfsf
https://any.themoviedb.org/tv/12345-gg/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}